TLS 1.1+ Security Update

TLS 1.1+ Compatible Browsers

(not a comprehensive list)


  • Google Chrome version 22 or higher
  • Android OS Browser 5.0 or higher
  • Mozilla Firefox version 27 or higher
  • Internet Explorer 11
  • Microsoft Edge (any version)
  • Safari version 9 or higher (OS X 10.9+)

For a complete list of compatible browsers, including mobile browsers, please visit this link: Transport Security Layer

Want to... ?

man with tie next to flag icon

Get in touch with us?
person touching tablet device

Now you can easily move recurring payments and direct deposits to a new account - all with the click of a mouse. With ClickSWITCH™, account information is transferred instantly. It’s fully automated, convenient, and takes as little as 10 minutes.

Find Out More